// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)\b([^\s\"]+)(\s+|)\:=\s+new\s+([^(]+)\(([^;\(\)]+)\);"#).unwrap();
let string = "create or replace package body ORA_MTK.Test_package_03 as
procedure do_something (n1 in NUMBER, n2 in out NUMBER,n3 in out NOCOPY NUMBER) as
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
aaa13 ty_base:= new ty_base(participantid => 'a',clientid => '1',price => 3);
begin
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
l_array13 := new tyt_base(ty_base(1,2,3));
aaa13 := new ty_base(participantid => 'a',clientid => '1',price => 3);
aaa14 := new ty_base(participantid => 'a', -- comment 01
clientid => '1' -- comment 01 ; ,
,price => 3);
aaa15 := new ty_base(participantid15 => 'a', -- comment 01
-- comment 02;
clientid15 => '1'
,price15 => 3);
aaa16.xxxx := new ty_base(participantid => 'a',clientid => '1',price => 3);
l_array(l_array.count) := NEW ty_base(participantid => 300,clientid => 2,price => 3);
l_array(l_array.count).xxxx := NEW ty_base(participantid => 300,clientid => 2,price => 3);
\"aaa 17\" := new ty_base(participantid => 'a',clientid => '1',price => 3);
end do_something;
end Test_package_03";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}