#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:import(?:\s*){addCssStyle}(?:\s*)from(?:\s*)"(?:[^"]*)")"
Local $sString = "import{addCssStyle}from"../addcss/addcss.prod.js";function elog(e){return console.error(e)}function isHTML(e){return e[Symbol.toStringTag].includes("Element")}function appendChild(e,t,n=!1){return isHTML(e)?isHTML(t)?(e.appendChild(t),void(n?loopOf(t):t?.checkParent&&t.checkParent())):elog(`${t[Symbol.toStringTag]} is not HTML Element`):elog(`${e[Symbol.toStringTag]} is not HTML Element`)}function append(e,t,n=!1){if(!isHTML(e))return elog(`${e[Symbol.toStringTag]} is not HTML Element`);if(Array.isArray(t)||(t=[t]),!Array.isArray(t)||!t.length)return elog(`${t} is undefined, at least HTML Element or its array`);if(e.append(...t),n)for(const e of t)e[Symbol.toStringTag].includes("Element")?loopOf(e):console.error(`${e[Symbol.toStringTag]} is not HTML Element`)}function loopOf(e){if(e?.checkParent&&e.checkParent(),0!==e.children.length)for(const t of e.children)t?.checkParent&&t.checkParent(),loopOf(t)}function replaceChildren(e,t,n=!1){if(!isHTML(e))return elog(`${e[Symbol.toStringTag]} is not HTML Element`);if(Array.isArray(t)||(t=[t]),e.replaceChildren(...t),n)for(const e of t)loopOf(e)}function getWidth(e){return Math.ceil(e.getBoundingClientRect().width)}function getHeight(e){return Math.ceil(e.getBoundingClientRect().height)}function getDim(e){const{width:t,height:n}=e?.getBoundingClientRect()??{width:0,height:0};return{width:t,height:n}}function getDimBefore(e,t){const n=e.cloneNode(!0);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")