#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+\.[0-9]+$"
Local $sString = "1,1" & @CRLF & _
",1" & @CRLF & _
",,,,," & @CRLF & _
"1" & @CRLF & _
"." & @CRLF & _
".1....1111" & @CRLF & _
"1.1" & @CRLF & _
".1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
".." & @CRLF & _
"This is 1,1 and this is 1.1" & @CRLF & _
"12.222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")