package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+\.[0-9]+$`)
var str = `1,1
,1
,,,,,
1
.
.1....1111
1.1
.1
12
123
..
This is 1,1 and this is 1.1
12.222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}