// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+\.[0-9]+$").unwrap();
let string = "1,1
,1
,,,,,
1
.
.1....1111
1.1
.1
12
123
..
This is 1,1 and this is 1.1
12.222";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}