#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(?<date>(\[|)(\d{4}-\d{2}-\d{2}(T| )\d{2}:\d{2}:\d{2}(\]|.+\d{2}:\d{2}\]|.+\d{2}:\d{2})))(?<message>.*?)$"
Local $sString = "[2022-10-31 10:16:22] main.ERROR: The "--only-trace" option does not exist." & @CRLF & _
"#0 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(143): Symfony\Component\Console\Input\ArgvInput->addLongOption('only-trace', 'test')" & @CRLF & _
"#1 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(79): Symfony\Component\Console\Input\ArgvInput->parseLongOption('--only-trace=te...')" & @CRLF & _
"#2 /var/www/magento/vendor/symfony/console/Input/Input.php(55): Symfony\Component\Console\Input\ArgvInput->parse()" & @CRLF & _
"[2022-10-31 10:16:22] main.ERROR: I'm a new group"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")