$re = '/\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})/m';
$str = 'Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024';
$subst = " $1-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;