# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*[^\d\r\n](\d+)/\1/gm;t' <<< "2^64
asdgaf1_hsg534
asdfh23_hsjd12
dgshg_jhfsd86
test
1
testing 1234 testing 1 test4
testing 1234 testing 123"