# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/required\\/)(?:identifier\\/optional1\\/optional2\\/)(.*)/$1$2/gm;t' <<< "/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2"