import Foundation
let pattern = #"(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)