#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[table]\R*([^[]*(?:\[(?!/?table])[^[]*)*)\R*\[/table]"
Local $sString = "" & @CRLF & _
"[b]Check out this demo[/b]" & @CRLF & _
"¯\_(ツ)_/¯" & @CRLF & _
"[table]" & @CRLF & _
"[**]header1[||]header2[||]header3[||]...[/**]" & @CRLF & _
"[*]child1.1[|]child1.2[|]child1.3[|]..." & @CRLF & _
"[*]child2.1[|]child2.2[|]child2.3[|]..." & @CRLF & _
"[*]child3.1[|]child3.2[|]child3.3[|]..." & @CRLF & _
"[*]...[|]...[|]...[|]..." & @CRLF & _
"[/table]" & @CRLF & _
"simple text" & @CRLF & _
"[table]" & @CRLF & _
"[**]a 1[||]and a 2[/**]" & @CRLF & _
"[*]A[|]B" & @CRLF & _
"[*]C[|]D" & @CRLF & _
"[/table]" & @CRLF & _
"" & @CRLF & _
"[s]3, you're out[/s]" & @CRLF & _
"blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")