re = /\[table]\R*([^[]*(?:\[(?!\/?table])[^[]*)*)\R*\[\/table]/
str = '
[b]Check out this demo[/b]
¯\\_(ツ)_/¯
[table]
[**]header1[||]header2[||]header3[||]...[/**]
[*]child1.1[|]child1.2[|]child1.3[|]...
[*]child2.1[|]child2.2[|]child2.3[|]...
[*]child3.1[|]child3.2[|]child3.3[|]...
[*]...[|]...[|]...[|]...
[/table]
simple text
[table]
[**]a 1[||]and a 2[/**]
[*]A[|]B
[*]C[|]D
[/table]
[s]3, you\'re out[/s]
blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end