package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\*](.*)`)
var str = `[table]
[**]header1[||]header2[||]header3[||]...[/**]
[*]child1.1[|]child1.2[|]child1.3[|]...
[*]child2.1[|]child2.2[|]child2.3[|]...
[*]child3.1[|]child3.2[|]child3.3[|]...
[*]...[|]...[|]...[|]...
[/table]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}