using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!Copy).*?-(\d{6})\.v";
string input = @"BS-123456.v2019
Copy_BS-123456.v2019
Copy-BS-123456.v2019
Copy BS-123456.v2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}