#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=\w{6,})(?=\w*\d{2})"
Local $sString = "bana12" & @CRLF & _
"abc123" & @CRLF & _
"8pass99" & @CRLF & _
"astr1on11aut" & @CRLF & _
"" & @CRLF & _
"banan1" & @CRLF & _
"astronaut" & @CRLF & _
"12345" & @CRLF & _
"1a2bcde"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")