using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<header>[^:\n]+):\s*(?P<value>.+)";
string input = @"ID: 1
Name: Jon Doe
Address: 123 Main St Anytown, USA
Age: 25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}