// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<header>[^:\n]+):\s*(?P<value>.+)").unwrap();
let string = "ID: 1
Name: Jon Doe
Address: 123 Main St Anytown, USA
Age: 25";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}