const regex = new RegExp('\\([A-Z]+(?!\\))\\b', 'gm')
const str = `The dog walked (ABC in the park
The dog walked (ABC) in the park
`;
const subst = `$0)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);