use strict;
my $str = 'The dog walked (ABC in the park
The dog walked (ABC) in the park
';
my $regex = qr~\([A-Z]+(?!\))\b~mp;
my $subst = '$0)';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";