import Foundation
let pattern = #"\([A-Z]+(?!\))\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The dog walked (ABC in the park
The dog walked (ABC) in the park
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)