use strict;
my $str = 'C:\\Photos\\Selfies\\1|
C:\\HDPhotos\\Landscapes\\2|
C:\\Filters\\Pics\\12345678|
C:\\Filters\\Pics2\\00000000|
C:\\Filters\\Pics2\\00000000|XAV7';
my $regex = qr/^(?!.*\\\d{8}\|$)(?P<file_path>.*)\|(?P<suffix>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}