import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*[\\s\\S]*?\\*\\/|(?<=[^:])\\/\\/.*|^\\/\\/.*";
final String string = "// other comment\n"
+ "//test\n"
+ "here /*test*/\n"
+ "alert('hello, this code has comments!')//An alert\n"
+ "/* A block comment here */\n"
+ "// A single line comment on a newline\n"
+ "/*\n"
+ "multiple lines*/\n"
+ "/** double asterisks */\n"
+ "//\n"
+ "some text\n"
+ "/**/\n"
+ "/*\n"
+ " * multiple lines again\n"
+ "*/\n"
+ "some text\n"
+ "/* here / there */\n"
+ "var url=\"https://www.website.com\";//comment";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}