const regex = /\/\*[\s\S]*?\*\/|(?<=[^:])\/\/.*|^\/\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*[\\s\\S]*?\\*\\\/|(?<=[^:])\\\/\\\/.*|^\\\/\\\/.*', 'gm')
const str = `// other comment
//test
here /*test*/
alert('hello, this code has comments!')//An alert
/* A block comment here */
// A single line comment on a newline
/*
multiple lines*/
/** double asterisks */
//
some text
/**/
/*
* multiple lines again
*/
some text
/* here / there */
var url="https://www.website.com";//comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}