#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))" & @CRLF & _
"|" & @CRLF & _
"(ProgrammingError: inf can not be used with MySQL)"
Local $sString = "(1054, "Unknown column 'infe0' in 'field list'")" & @CRLF & _
"(1054, "Unknown column 'inf' in 'field list'")" & @CRLF & _
"ProgrammingError: inf can not be used with MySQL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")