package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)`)
var str = `(1054, "Unknown column 'infe0' in 'field list'")
(1054, "Unknown column 'inf' in 'field list'")
ProgrammingError: inf can not be used with MySQL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}