$re = '/(\(1054, "Unknown column \'inf(e0)?\' in \'field list\'"\))
|
(ProgrammingError: inf can not be used with MySQL)/xm';
$str = '(1054, "Unknown column \'infe0\' in \'field list\'")
(1054, "Unknown column \'inf\' in \'field list\'")
ProgrammingError: inf can not be used with MySQL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);