re = /(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)/xm
str = '(1054, "Unknown column \'infe0\' in \'field list\'")
(1054, "Unknown column \'inf\' in \'field list\'")
ProgrammingError: inf can not be used with MySQL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end