import Foundation
let pattern = #"""
(\(1054, "Unknown column 'inf(e0)?' in 'field list'"\))
|
(ProgrammingError: inf can not be used with MySQL)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
(1054, "Unknown column 'infe0' in 'field list'")
(1054, "Unknown column 'inf' in 'field list'")
ProgrammingError: inf can not be used with MySQL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)