const regex = new RegExp('\\),[^\\S\\n]*(?=\\w)', 'gm')
const str = `text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line`;
const subst = `),\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);