// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\([^()\n]*ppm\b[^()]*\)").unwrap();
let string = "\"Menthol(0.3ppm)\" ===> \"Menthol\"
\"Michale(36 years old man)\" ===> \"Michale(36 years old man)\"
\"Good(5%, 5,500ppm)\" ===> \"Good\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}