import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)";
final String string = "US-LegolandFlorida-ScreenLineup.csv\n"
+ "US-39148-Floor6_S1-Lineup.csv\n"
+ "US-39148-Floor6_S1-Disclaimers.csv\n"
+ "US-39148-S3-Lineup.csv\n"
+ "US-39148-S3-Disclaimers.csv\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}