$re = '/(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)/m';
$str = 'US-LegolandFlorida-ScreenLineup.csv
US-39148-Floor6_S1-Lineup.csv
US-39148-Floor6_S1-Disclaimers.csv
US-39148-S3-Lineup.csv
US-39148-S3-Disclaimers.csv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);