#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\p{Lu}\w+)=(\s?[.\s@\w\-]+)"
Local $sString = "Dec 17 10:08:38 10.52.137.1 Apr 3 22:46:57 2012 930|RTR-944 %%10SC/6/SC_AAA_LAUNCH(l): |DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system; AAA launched." & @CRLF & _
"DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")