const regex = /(\p{Lu}\w+)=(\s?[.\s@\w\-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\p{Lu}\\w+)=(\\s?[.\\s@\\w\\-]+)', 'g')
const str = `Dec 17 10:08:38 10.52.137.1 Apr 3 22:46:57 2012 930|RTR-944 %%10SC/6/SC_AAA_LAUNCH(l): |DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system; AAA launched.
DevIP=10.52.137.1|AAAType=AUTHEN|AAAScheme= hwtacacs-scheme tacacs|Service=login|UserName=monitor@system`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}