using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\S]*?)(src=['""])\/uploads\/images\/.+?(\..+?)(['""]>[\s\S]*?src=['""])\/uploads\/images\/.+?\..+?(['""]>[\s\S]*?src=['""])\/uploads\/images\/.+?\..+?(['""]>[\s\S]*)";
string substitution = @"$1$2some/value/one$3$4alue/SomethingElse\.png$5Value3$6";
string input = @"some text with <img src='/uploads/images/5d0554.jpeg'> and
<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}