use strict;
my $str = 'some text with <img src=\'/uploads/images/5d0554.jpeg\'> and
<img src=\'/uploads/images/507a.jpeg\'> or <img src=\'/uploads/images/0a74.jpeg\'> in it.';
my $regex = qr/([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)/mp;
my $subst = '$1$2some/value/one$3$4alue/SomethingElse\\.png$5Value3$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";