// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)"#).unwrap();
let string = "some text with <img src='/uploads/images/5d0554.jpeg'> and
<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it.";
let substitution = "$1$2some/value/one$3$4alue/SomethingElse\\.png$5Value3$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}