#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<mrow[^>]*>\(?((?:(?!</?mrow\b[^>]*>).)*?)\)?</mrow>"
Local $sString = "<msub><mi>y</mi><mrow>(<mi>n</mi><mo>+</mo><mn>1</mn>)</mrow></msub><mo>=</mo><msub><mi>y</mi><mrow>(<mi>n</mi><mo>-</mo><mn>1</mn>)</mrow></msub><mo>*</mo><msup><mrow>(<msub><mi>y</mi><mi>n()</mi></msub>)</mrow><mrow><mn>2</mn></mrow></msup>" & @CRLF & _
"" & @CRLF & _
"<mrow>(<mn>1000001</mn>)</mrow>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")