import Foundation
let pattern = #"<mrow[^>]*>\(?((?:(?!</?mrow\b[^>]*>).)*?)\)?</mrow>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<msub><mi>y</mi><mrow>(<mi>n</mi><mo>+</mo><mn>1</mn>)</mrow></msub><mo>=</mo><msub><mi>y</mi><mrow>(<mi>n</mi><mo>-</mo><mn>1</mn>)</mrow></msub><mo>*</mo><msup><mrow>(<msub><mi>y</mi><mi>n()</mi></msub>)</mrow><mrow><mn>2</mn></mrow></msup>
<mrow>(<mn>1000001</mn>)</mrow>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)