const regex = /^(?:\p{L}['´ \-]?)+(?<=[^\s\-'´])$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\p{L}[\'´ \\-]?)+(?<=[^\\s\\-\'´])$', 'gmu')
const str = `Valid firstnames:
-----------------
Jean-Jacques
O'Neill
O´Neill
De Lee
Élodie
Michèle
Invalid first names:
--------------------
Bertrand!
Focus123
Spaceafter
Space before
Two spaces
Hyphen-at-end-
Two--hyphens
Ooo´
1234
email@domain.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}