$re = '/^(?:|(https?:\/\/)?(|www)[.]?((t|telegram)\.me)\/joinchat\/)[a-zA-Z0-9_]{5,32}$/m';
$str = 'https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ
t.me/joinchat/I5antRHvea8ohaU7_RsYYQ
telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);