import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^)(Prefix:[a-zA-Z0-9][\\w.-]*[^.]#\\d+)(?:\\s|$)";
final String string = "Prefix:middle#113 build: xxxxxx Prefix:middle#6\n"
+ "Prefix:middle#16026Prefix:middle#1111\n"
+ " Prefix:middle#110 Prefix:middle.#2 Prefix:middl.e#111 Prefix:middle#112";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}