package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\s]*(?:\([^)]*\)[\w\s]*)*)(\W)`)
var str = `Foo (.*) bar blla (.*) b*l?a$ && bla bla `
var substitution = "$1\\$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}