re = /([\w\s]*(?:\([^)]*\)[\w\s]*)*)(\W)/
str = 'Foo (.*) bar blla (.*) b*l?a$ && bla bla '
subst = '$1\\\\$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result