re = /(?<!\(\.)([*?$&])(?!\))/
str = 'Foo (.*) bar blla (.*) b*l?a$ && bla bla '
subst = '\\\\$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result