// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$").unwrap();
let string = "0
1
12
123
0.1
1.12
12.0123
1.23
-1
-12
-0.1
-1.12
-12.0123
-01.23
01.23
3000001230120312030123011.2323
12.
--123
-2323-
23.23.23
34..34";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}