// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Dealer:").unwrap();
let string = "Dealer: callawaykid wins 428 chips
Dealer: ** Hand [ 1288159259 ] started **
Dealer: Dealt to board: [ 4h Qh 2c ]
Dealer: Dealt to board: [ 8h ]
Dealer: Dealt to board: [ 6d ]
Dealer: Showdown: Main pot, 380 chips
Dealer: centraliaxxx mucks
Dealer: centraliaxxx wins 380 chips
Dealer: ** Hand [ 1288159639 ] started **";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}