# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:="|"\s+(?:\w+="|\\/>))(*SKIP)(?!)|"//g;t' <<< "<record ObTime=\"2017-05-10T23:30\" data_value=\"Ocean Park \"The Sea WX\" WA US\" />
"