re = /(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|"/
str = '<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result