import Foundation
let pattern = #"(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)